Profile: Paul

Statistics
Avatar
  • 8

Hello Patryk,
Which json? Is it appsettings.json file?
Thanks.
Paul.

Monday, November 19, 2018 12:53 PM

Describe your problem: When clicking the picture thumbnails instead of changing the main product image, the full picture pop-up shows up. I think before 4.30 the pop-up was displayed when clicking on the main picture and not on the thumbnails.

Version of GrandNode: 4.30

Did you make any private modifications of GrandNode?: No

Saturday, November 17, 2018 6:35 PM

The test site: firstchoicechannel.com

Right now on
1. Laptop/Linux/Firefox 62.0.3 (64-bit) - the Books category does not show any pictures
2. iPhone 6s: Safari no pictures at all on any categories. Chrome the only pictures are missing are from the books category.

The checkout still not working neither as a guest nor as a registered user.

This is only a test site.

Monday, October 8, 2018 7:22 PM

Update: As another example of the same behavior. Almost always the pictures for the categories set to Show on home page are missing but the rest of the pictures are visible.

If I log in as with the main account every pictures shows up.

Paul.

Monday, October 8, 2018 5:14 PM

My mistake as above I have pasted another  /etc/nginx/conf.d/default.conf.
Basically I am redirecting all HTTP requests to HTTPS as recommended by:
https://mozilla.github.io/server-side-tls/ssl-config-generator/:
for OpenSSL 1.0.2g and NGINX version 1.14.0
and customizing the rest of the file based on my application current settings.
(I can not paste the code as I can not select the content of the file using DigitalOcean's console)

server {
  listen 80;

   # Redirect all HTTP requests to HTTPS with a 301 Moved Permanently response.
    return 301 https://$host$request_uri;
    }
server {
listen 443 ssl http2;
listen [::] : 443 ssl http2;

ssl on;
...customized GrandNode setting....

}

Sunday, October 7, 2018 4:22 PM

Followed the instructions from GrandNode Blog with installation as follows:

Version of GrandNode: 4.20.01
Version of MongoDB: 4.0.2
OS: Ubuntu 16.04.5 on Digital Ocean
NGINX version 1.14.0
OpenSSL 1.0.2g
Both GrandNode and MongoDB on the same droplet.
ufw firewall in Ubuntu: enabled or disabled - same behavior
Digital Ocean firewall:
Inbound Rules on: for HTTP   TCP   80 and 443   for All IPv4 All IPv6
Outbound Rules on: ICMP, All TCP, All UDP for All IPv4 All IPv6

Problem:
As I am trying to setup Digital Ocean firewall and setup new categories and products from time to time pictures are not showing up. Including the ones specific to the store , like logo (not only related to products).

It is becoming more obvious  (no pictures at all) when disabling HTTP in the Inbound Rules in Digital Ocean firewall or outbound rules.

In /etc/nginx/conf.d/default.conf,  I am redirecting all HTTP requests to HTTPS as recomended by:
https://mozilla.github.io/server-side-tls/ssl-config-generator/:
for OpenSSL 1.0.2g and NGINX version 1.14.0

server {
  listen 80;

   # Redirect all HTTP requests to HTTPS with a 301 Moved Permanently response.
    return 301 https://$host$request_uri;
    }
server {
  listen 443;
  server_name testapp.rubytreesoftware.com;
  root /opt/www/testapp/current/public;

  location ^~ /assets/ {
    gzip_static on;
    expires max;
    add_header Cache-Control public;
  }

  ssl                  on;
  ssl_certificate      /etc/ssl/certs/secure.rubytreesoftware.com.1.2016.chain.crt;
  ssl_certificate_key  /etc/ssl/private/secure.rubytreesoftware.com.1.key;

  ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
  ssl_ciphers   "EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES256-GCM-SHA384:AES128-GCM-SHA256:AES256-SHA256:AES128-SHA256:AES256-SHA:AES128-SHA:DES-CBC3-SHA:HIGH:!aNULL:!eNULL:!EXPORT:!DES:!MD5:!PSK:!RC4";

  ssl_prefer_server_ciphers   on;
  ssl_session_timeout  10m;  
  ssl_session_cache shared:SSL:10m;
  ssl_stapling on;

  try_files $uri/index.html $uri @unicorn;
  location @unicorn {
    proxy_set_header Host $host;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Proto $scheme;
    proxy_redirect off;
    proxy_pass http://unicorn_testapp;
  }
  
  error_page 500 502 503 504 /500.html;
  client_max_body_size 4G;
  keepalive_timeout 10;  
}  
    

Sunday, October 7, 2018 3:09 PM

Setup Continued (firewall)
-ufw firewall in Ubuntu: enabled or disabled - same behaviour
-Digital Ocean firewall:
Inbound Rules on: for HTTP   TCP   80 and 443   for All IPv4 All IPv6
Outbound Rules on: ICMP, All TCP, All UDP for All IPv4 All IPv6

Sunday, October 7, 2018 2:46 PM

Orders do not get pass the 1. Billing address. when selecting the address and click Continue it goes back to the Shopping Cart

Followed the instructions from GrandNode Blog with installation as follows:

Version of GrandNode: 4.20.01
Version of MongoDB: 4.0.2
OS: Ubuntu 16.04.5 on Digital Ocean
NGINX version 1.14.0
Both GrandNode and MongoDB on the same droplet.

Everything seams to work fine in the Admin Panel when adding/updating products or Categories, until trying to complete an order.
I add an item(s) to the shopping cart,
1. select Go To Cart,
2. Check :I agree with the terms of service and I adhere to them unconditionally(read)
3. Click: Checkout
4. Takes me to the first step 1. Billing address: Select an address (or type a new address)
5, Click Continue and it takes me back to the shopping card.
It does not get pass the 1. Billing address

Please advise
Thank you.
Paul.

Sunday, October 7, 2018 2:39 PM