System requirements

In order to run GrandNode, you will need the following installed on your server / computer:

.NET Core supported Windows versions

.NET Core is supported on the following versions of :

  • Windows 7 SP1
  • Windows 8.1
  • Windows 10, Windows 10 Anniversary Update (version 1607) or later versions
  • Windows Server 2008 R2 SP1 (Full Server or Server Core)
  • Windows Server 2012 SP1 (Full Server or Server Core)
  • Windows Server 2012 R2 (Full Server or Server Core)
  • Windows Server 2016 (Full Server, Server Core, or Nano Server)

.NET Core supported MacOS versions

.NET Core 2.x is supported on the following versions of macOS:

  • macOS 10.12 "Sierra" and later versions

Visual Studio for Mac

You can use any editor to develop .NET Core applications using the .NET Core SDK. However, if you want to develop .NET Core applications on a Mac in an integrated development environment, you can use Visual Studio for Mac.

.NET Core development on macOS with Visual Studio for Mac requires:

.NET Core supported Linux versions

.NET Core 2.0 treats Linux as a single operating system. There is a single Linux build (per chip architecture) for supported Linux distros.

NET Core 2.x is supported on the following Linux 64-bit (x86_64 or amd64) distributions/versions:

  • Red Hat Enterprise Linux 7
  • CentOS 7
  • Oracle Linux 7
  • Fedora 25, Fedora 26
  • Debian 8.7 or later versions
  • Ubuntu 17.04, Ubuntu 16.04, Ubuntu 14.04
  • Linux Mint 18, Linux Mint 17
  • openSUSE 42.2 or later versions
  • SUSE Enterprise Linux (SLES) 12 SP2 or later versions

Linux distribution dependencies

The following are intended to be examples. The exact versions and names may vary slightly on your Linux distribution of choice.

Ubuntu

Ubuntu distributions require the following libraries installed:

    • libunwind8
    • liblttng-ust0
    • libcurl3
    • libssl1.0.0
    • libuuid1
    • libkrb5
    • zlib1g
    • libicu52 (for 14.X)
    • libicu55 (for 16.X)
    • libicu57 (for 17.X)

CentOS

CentOS distributions require the following libraries installed:

  • libunwind
  • lttng-ust
  • libcurl
  • openssl-libs
  • libuuid
  • krb5-libs
  • libicu
  • zlib

IIS 8.0 or above

ASP.NET Core 2.0

Supported databases:

  • MongoDB 3.4 or above

Supported browsers:

  • Microsoft Internet Explorer 11
  • Mozilla Firefox 2.0 and above
  • Google Chrome 1.x
  • Apple Safari 2.x

MS Visual Studio 2017with ASP.NET Core 2.0 installed