Saturday, June 15, 2019 11:04:44 PM
  • Posted: Monday, April 15, 2019 7:07 PM
  • 22
We have followed the steps in the install guide, but still get errors when uploading product images.

We got this to work on our Win/IIS setup, but not Linux/Docker. I don't have direct access  to the Linux server, but the CTO has confirmed that access rights are set to RW.

From log in /Admin/Log/List:

Access denied to user #x@y.com 'x@y.com' on /Admin/Picture/AsyncUpload

Any suggestions are appreciated!
0
  • Posted: Monday, April 15, 2019 7:29 PM
  • Moderator
  • 24
Hi,
New version (4.40) has addition permission about uploaded files.
Please go to admin panel -> Configuration -> Access control list -> please find "Admin area. Manage Files" and give rights.

Best Regards
Krzysztof
0
  • Posted: Monday, April 15, 2019 8:14 PM
  • 22
Thanks a lot, we'll upgrade and add this setting.

Could you explain very short what's done "behind the scenes" here, compared to previous versions?
0
  • Posted: Tuesday, April 16, 2019 6:44 AM
  • Moderator
  • 24
What kind of version are you use? Permission "Admin area. Manage Files" is a standard feature from version 4.40.
If your database comes from develop version (before release 4.40), then can be without some records in database.
If your database comes from version 4.30, you should upgrade it.
0