Trying to get custom added plugins working with Google Cloud Run

Sunday, October 24, 2021 8:29:25 AM
  • Posted: Tuesday, October 12, 2021 10:11 AM
  • 2
Hello,

I am trying to get Grandnode plugins working with Google Cloud Run.

Currently trying with version 4.80.  I know it is old, but this is where all my plugins are developed to, currently.
I will upgrade to Grandnode 2.0 soon.

Application is installed via Docker file and plugins are installed via Copy and then built as was shown in the docker file.

For example:
COPY Plugins/Grand.Plugin.Api.Extended/Grand.Plugin.Api.Extended.csproj Plugins/Grand.Plugin.Api.Extended/Grand.Plugin.Api.Extended.csproj
RUN dotnet build Plugins/Grand.Plugin.Api.Extended/Grand.Plugin.Api.Extended.csproj

I can see that the Plugins are generated in app/Plugins/Api.Extended folder as such:

Grand.Core.dll    Grand.Framework.dll         Grand.Plugin.Api.Extended.deps.json  Grand.Services.pdb
Grand.Core.pdb    Grand.Framework.pdb         Grand.Plugin.Api.Extended.dll      Views
Grand.Domain.dll  Grand.Plugin.Api.Common.dll  Grand.Plugin.Api.Extended.pdb      logo.jpg
Grand.Domain.pdb  Grand.Plugin.Api.Common.pdb  Grand.Services.dll

I can see that correct dll file is placed in the app/Plugins
Grand.Plugin.Api.Extended.dll

But, I am unable to see my plugins in admin plugin list in Cloud Run.  I can only see the default plugins.
So what could the issue be here?  
If I run in debug from Visual studio I see the added plugins fine and they install.

One more issue which could possibly be the whole problem is that with Google Cloud Run everything is static.  
So I am unable to persist things here.  Well it maybe possible, but that is another whole setup to look at, so I start simple for now.  
So my other question is there a way to setup plugins to be installed by default?
This would solve the issue here as we only want to use and have installed the plugins which we specify in the docker file.

I greatly appreciate any help on this.
0
  • Posted: Tuesday, October 12, 2021 11:57 AM
  • 2
Well, of course I figured it out after I posted here.  

1. I found out that I was not using the updated image when I deployed to cloud run.  

2. I guess I was on the right track in that everything worked locally.  I noticed that as I added plugins I saw that plugins where added to the InstalledPlugins.txt file.
So I found that I can add all my plugins to this file and they are installed and work properly on the cloud run servers. This is a big plus!

Still have to do more testing, but seems like everything is working now.  
So as far as I can tell I Grandnode 4.80 runs on Google Cloud Run.  

0
back to top
Filters