very much resource use

Sunday, February 5, 2023 9:16:42 PM
  • Posted: Wednesday, September 19, 2018 2:02 PM
  • 9
hello , i have used grandnode 4.2 as infrastructure in my project after deploying it on linux vps i noticed that it consume very much data.
and in your 4.3 version i have seen that you have announced a fix for this problem , can you tell me where were the issue to fix it as i cannot move to version 4.3 because i created some changes to let it match my project needs
.Net Developer
0
  • Posted: Thursday, September 20, 2018 6:38 AM
  • 953
Hello,

Performance changes we've made in GrandNode 4.20.01, not 4.30. GrandNode 4.30 is still develop version, unstable, so it's not recommended to deploy it. You can look at our GitHub, you will find commits related with version 4.20.01 - it will help you to add changes responsible for GrandNode performance.
Best regards,
Patryk

GrandNode Team
0
  • Posted: Thursday, September 20, 2018 9:08 AM
  • 9
sorry i meant grand 4.1 (the first version with docker) not 4.2 i just missed the correct version
.Net Developer
0
  • Posted: Thursday, September 20, 2018 11:10 AM
  • 953
You can still use GitHub and compare this versions. Look at it here:
https://github.com/grandnode/grandnode/compare/Release-4.10...Release-4.20.01
Best regards,
Patryk

GrandNode Team
0
  • Posted: Monday, September 24, 2018 10:32 AM
  • 9
after comparison i only found this commit about memory
https://github.com/grandnode/grandnode/commit/b7542624ec38829bb2b1556dfa1fe804409e9b18
was that the only problem?
.Net Developer
0
  • Posted: Tuesday, September 25, 2018 6:55 AM
  • 953
Hello Hassan,

No, please try to add this setting in the web.config file:
<ServerGarbageCollection>false</ServerGarbageCollection>

Best regards,
Patryk

GrandNode Team
0
  • Posted: Wednesday, September 26, 2018 7:53 PM
  • 9
yea thanks a lot i tried it and i guess the consume of ram decreased i will watch it for a bit longer to check if the problem still there.
NOTE * "it's in Grand.Web.csproj Not in web.config"
.Net Developer
0
  • Posted: Friday, September 28, 2018 5:41 AM
  • 953
Hassan wrote:
yea thanks a lot i tried it and i guess the consume of ram decreased i will watch it for a bit longer to check if the problem still there.
NOTE * "it's in Grand.Web.csproj Not in web.config"


Yes, you are right. I thought about Grand.Web.csproj. Thanks for note.
Best regards,
Patryk

GrandNode Team
0
back to top
Filters