Set Google Analytics Up

Tuesday, July 14, 2020 8:55:32 AM
  • Posted: Thursday, June 25, 2020 9:10 PM
  • 2
Hello everyone,

Im relatively new to GrandNode and after setting an instance we're trying to set Google Analytics set up.
We already have a service account at Analytics side (App Engine Default) and set the corresponding Private Key, Service Account Email and and View ID...thing is, nothing is displayed under the Dashboard visuals and neither at Analytics Real Time dashboards.

At this point, we're not sure if the problem is at the service account level (which have full rights) or at GrandNode instance (we're currently using http protocol).
Does anybody have a clue about the possible issue or a pretty good tutorial to follow? I already took a look at the internet but only find a quick video from 2018 which is not updated against the current organization of Analytics.

Thanks!
0
  • Posted: Friday, June 26, 2020 5:34 AM
  • Team
  • 622
Hello,

First of all to collect data from store to Google Analytics, you need to configure the Google Analytics Widget. You can find it in Configuration -> Local plugins. Install it, if not installed, enable and configure (/Admin/WidgetsGoogleAnalytics/Configure). The configuration is very simple. You need to insert the Tracking ID there. If you grant permissions to service e-mail on your Analytics account and you successfully configured the Google Analytics Widget, you should also enable the Google Analytics API on your Google Account here.
Best regards,
Patryk

GrandNode Team
1
  • Posted: Friday, June 26, 2020 7:16 PM
  • 2
Thanks a lot Patryk!!

This was the missing setup i needed to complete first, I appreciate your time over this matter.
Nice weekend ahead :)
0
  • Posted: Monday, June 29, 2020 5:36 AM
  • Team
  • 622
That's great, I'm glad that it's working.
Best regards,
Patryk

GrandNode Team
0
back to top
Filters