Installation Theme Editor - 413 Request Entity Too Large

Sunday, December 5, 2021 5:45:08 PM
  • Posted: Tuesday, October 6, 2020 3:19 PM
  • 8
Hello,

I just purchased the Theme Editor and when trying to upload through the /Admin/Plugin/List, I receive the following error.

413 Request Entity Too Large
nginx/1.14.0 (Ubuntu)

I've tried to load the standard downloaded Zip file with three version (4.50, 4.60, 4.70) and as it did not work, tried to setup a Zip file with only the 4.60 version (also without success).

It's a "digitalocean" droplet installation type.

Thanks,

Mark
0
  • Posted: Wednesday, October 7, 2020 5:37 AM
  • Team
  • 947
Hi Mark,

It's a problem related with nginx. In the ngix default configuration you are allowed to upload only max 1.5mb. In /etc/nginx/nginx.conf in the server { line, you need to add this line:  client_max_body_size 5M; (to be honest it can be anything, but in the case of Theme Editor, it's enough to set 5 MB limit).
Best regards,
Patryk

GrandNode Team
0
  • Posted: Wednesday, October 7, 2020 9:32 AM
  • 8
Patryk wrote:
Hi Mark,

It's a problem related with nginx. In the ngix default configuration you are allowed to upload only max 1.5mb. In /etc/nginx/nginx.conf in the server { line, you need to add this line:  client_max_body_size 5M; (to be honest it can be anything, but in the case of Theme Editor, it's enough to set 5 MB limit).


Hello,

Does not seem to work. I've added your recommendations in the code but without success. What am I doing wrong ?
Below the code:
user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
  worker_connections 768;
  # multi_accept on;
}

http {

  ##
  # Basic Settings
  ##
        client_max_body_size 15M;
  sendfile on;
  tcp_nopush on;
  tcp_nodelay on;
  keepalive_timeout 65;
  types_hash_max_size 2048;

  # server_tokens off;

  # server_names_hash_bucket_size 64;
  # server_name_in_redirect off;

  include /etc/nginx/mime.types;
  default_type application/octet-stream;

  ##
  # SSL Settings
  ##

  ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
  ssl_prefer_server_ciphers on;

  ##
  # Logging Settings
  ##

  access_log /var/log/nginx/access.log;
  error_log /var/log/nginx/error.log;

  ##
  # Gzip Settings
  ##

  gzip on;

  # gzip_vary on;
  # gzip_proxied any;
  # gzip_comp_level 6;
  # gzip_buffers 16 8k;
  # gzip_http_version 1.1;
  # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

  ##
  # Virtual Host Configs
  ##

  include /etc/nginx/conf.d/*.conf;
  include /etc/nginx/sites-enabled/*;
}


#mail {
#  # See sample authentication script at:
#  # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#  # auth_http localhost/auth.php;
#  # pop3_capabilities "TOP" "USER";
#  # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#  server {
#               client_max_body_size 15M;
#    listen     localhost:110;
#    protocol   pop3;
#    proxy      on;
#  }
#
#  server {
#    
#    client_max_body_size 15M;
#    listen     localhost:143;
#    protocol   imap;
#    proxy      on;
#  }
#}

0
  • Posted: Wednesday, October 7, 2020 9:33 AM
  • Team
  • 947
Look at the end of the file and server {} line. Just remove the #. It's a commented line.

// Edit, Mark, I've got confused, please ignore the above-mentioned line, it is responsible for e-mail configuration.

A while ago, I've checked your configuration on our test server, and everything works fine. It's enough to add it to the HTTP {} block. When you save changes, you should also reload the Nginx service with systemctl reload nginx command. Have you done that?
Best regards,
Patryk

GrandNode Team
0
  • Posted: Wednesday, October 7, 2020 11:57 AM
  • 8
Patryk wrote:
Look at the end of the file and server {} line. Just remove the #. It's a commented line.

// Edit, Mark, I've got confused, please ignore the above-mentioned line, it is responsible for e-mail configuration.

A while ago, I've checked your configuration on our test server, and everything works fine. It's enough to add it to the HTTP {} block. When you save changes, you should also reload the Nginx service with systemctl reload nginx command. Have you done that?


Hello Patryk,

I found out about the e-mail block and did implement it for HTTP as follows:

http {

  ##
  # Basic Settings
  ##
  sendfile on;
  tcp_nopush on;
  tcp_nodelay on;
  keepalive_timeout 65;
  types_hash_max_size 2048;
  client_max_body_size 20m;

Now it seems the file is loaded completely but comes out then to a 404 error page (Page not found).

Cette page du site 159.89.11.243 est introuvable
Aucune page Web trouvée à l'adresse :http://159.89.11.243/Admin/Plugin/UploadPlugin
HTTP ERROR 404

Sorry if I'm asking beginner's questions.

Thanks,

Mark


0
  • Posted: Wednesday, October 7, 2020 12:32 PM
  • Team
  • 947
Mark,
I've sent you a message via our ticket system. Can you check it?
Best regards,
Patryk

GrandNode Team
0
back to top
Filters