Unauthorized Access Exception

Sunday, February 5, 2023 10:36:27 PM
  • Posted: Saturday, March 27, 2021 5:42 AM
  • 82
Dear,
My website occasionally shows the following error:-"Unauthorized Access Exception-Access to Path -"C:\inetpub\www\qomash\plugins\bin\grand.plugin.shipping.shippingpoint.dll" is denied". But when I restart IIS the Issue gets resolved. What can the posible reason for this error?

Also how can I set a generic error page instead of showing these errors on public site
0
  • Posted: Monday, March 29, 2021 12:24 PM
  • 953
Hi,

This problem shouldn't appear in the newest version.
Best regards,
Patryk

GrandNode Team
0
  • Posted: Monday, March 29, 2021 12:27 PM
  • 82
Patryk wrote:
Hi,

This problem shouldn't appear in the newest version.

But my application is Hosted with version-4.7
0
  • Posted: Monday, March 29, 2021 12:46 PM
  • 953
So I recommend to upgrade it to the newest version.

In the case of displaying full stack error trace, you can disable it in the appsettings.json file, just set it to false.
Best regards,
Patryk

GrandNode Team
0
  • Posted: Monday, March 29, 2021 1:21 PM
  • 82
Patryk wrote:
So I recommend to upgrade it to the newest version.

In the case of displaying full stack error trace, you can disable it in the appsettings.json file, just set it to false.


But its is already set to false.

Dear Patryk, I cannot upgrade to the new version as I have custom code changes added to the verison4.7. Kindly can you let me understand the cause of reason, so thta I can fix in my version of Source code
0
  • Posted: Tuesday, March 30, 2021 6:01 AM
  • 953
Samson,

You can track source code changes between versions. We always recommend to implement changes as a plugins, such approach gives you flexibility in the upgrade process. In the other case, we can look at your code, premium support was created for such cases.
Best regards,
Patryk

GrandNode Team
0
  • Posted: Wednesday, March 31, 2021 2:38 PM
  • 82
Patryk wrote:
So I recommend to upgrade it to the newest version.

In the case of displaying full stack error trace, you can disable it in the appsettings.json file, just set it to false.


Dear Patryk,

Even though it is set to false, the full error gets displayed on site. Why is that so? Any other alternate method to not display the scary error to the customer?
0
  • Posted: Thursday, April 1, 2021 6:04 AM
  • 953
Samson,

If you disable displaying full error stack trace, your customers will see only "We're sorry an error occured", otherwise, they will see the whole error. I've checked it a while ago and it works fine.
Best regards,
Patryk

GrandNode Team
0
  • Posted: Thursday, April 1, 2021 6:48 AM
  • 82
Dear Patryk,

I fugured out the issue. My production shows hosting environment as development. But how did that happen. ? I published the source code on release mode.

Now What can I do to change it to production environment? Please advice
0
  • Posted: Monday, April 12, 2021 6:14 AM
  • 33
Samson wrote:
What can I do to change it to production environment?

Have a look at web.config file.
Best regards,
Tomasz

GrandNode Team
0
back to top
Filters