Thursday, June 20, 2019 5:54:50 PM
  • Posted: Thursday, November 29, 2018 2:04 PM
  • 48
I fixed this problem before on a previous install, but forgot what I did.  Trying to replicate the old setup I have been unable to solve this issue.
Occurs on the homepage.  If I recall it was an nginx configuration.  


Ubuntu 18.04 setup with nginx and dotnet core 2.1
- latest pull on GrandNode

0
  • Posted: Thursday, November 29, 2018 2:09 PM
  • 48

$ grep -r "Forwarded" .

./App_Data/appsettings.json:    "UseHttpXForwardedProto": true,
./App_Data/appsettings.json:    "ForwardedHttpHeader": "",
./App_Data/appsettings.json:    "UseForwardedHeaders": true   <--- recently set this for testing purposed


----------------
sites-available Location directive:

    proxy_pass http://localhost:5000;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection keep-alive;
    proxy_set_header Host $host;
    proxy_set_header X-Forwarded-Proto $scheme;
    proxy_cache_bypass $http_upgrade;

-------------------

Admin > Configuration > Store
* SSL enabled with the address set to the https://mydomain.com
0
  • Posted: Thursday, November 29, 2018 2:39 PM
  • 48
Will run through:
https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/linux-nginx?view=aspnetcore-2.1&tabs=aspnetcore2x

and report back if anything changes.
0
  • Posted: Friday, November 30, 2018 6:59 AM
  • Moderator
  • 257
Hello,

Just set the "UseHttpXForwardedProto" to false. From the GrandNode 4.30 it's enough to leave enabled only UseForwardedHeaders. And it should work.

In the default.conf file did you configure the SSL?
0
  • Posted: Friday, November 30, 2018 12:42 PM
  • 48
Appreciate the reply.  Appears to be working by setting the Proto forwarding in appsettings.json to false and ForwardedHeaders to true.  
- To answer your question.  Yes, all of the SSL settings are configured.

Aside: I would move this topic to the Installing and Configuring subsection, if I could.
0