Wednesday, March 20, 2019 3:09:14 PM
  • Posted: Saturday, December 15, 2018 12:28 AM
  • 48
Platform: Linux , GrandNode 4.3

Extracted the contents of MarketTheme.zip/MarketTheme into the Themes folder.  Set up the proper permission.
Moved the MarketTheme.zip/Widgets.MarketTheme into the Widgets folder. Set up the proper permissions.

Selected the Market Theme via Settings > General.  

The Market Theme widget is not viewable in Plugins or Widgets.  Selecting a category from the main navigation and several other locations I get:
MARKETTHEME.COLUMNS.TOGGLE in the main left navigation of the Market Theme hamburger menu drop down.

In the footer, several of the settings are placeholded by items like:

MARKET.CONTACT.INFORMATION

MARKET.NAME
market.address

--- etc.  

Any help is appreciated.
0
  • Posted: Saturday, December 15, 2018 3:58 PM
  • 48
Warnings in the admin panel:

* 'Widgets.MarketTheme' plugin is incompatible with your grandnode version. Delete it or update to the latest version.

Plugins/Widgets.MarketTheme/Description:
Version: 1.02
SupportedVersions: 4.30

I changed the SupportedVersions to 4.40 and was able to see the MarketTheme in Plugins.  After 'installing' the theme everything appears to be working as initially expected.


0
  • Posted: Saturday, December 15, 2018 4:29 PM
  • 48
Appears I may have spoken too soon.  

1) market.address is still filled in for the footer regardless of the value set for the address in admin settings.

2) after switching the colour of the Market Theme (i.e. selecting dark) there is no way to revert back to the original:
- i.e. http://markettheme.grandnode.com/ which is preferred.

3) small other things exist, for example the shopping cart has '0' versus the http://markettheme.grandnode.com/ version
of "0 item(s)"
0
  • Posted: Saturday, December 15, 2018 4:40 PM
  • 48
warning associated with market.address:

Resource string (market.address) is not found. Language ID = 5c01bbcaf44b120b55de66bf

Does not look like there is an associated Value with the String Resource 'market.address'

market.name seems to have Address associated as a value, not exactly sure what the reasoning is here.  
I am assuming it should be market.address.name -> Address
and another market.address linked back to the store information field for Address.  


For the mean time to fix this, I just added a new record to the English Language String resources section for market.address and manually filled in the address.  
0
  • Posted: Monday, December 17, 2018 7:49 AM
  • Moderator
  • 198
Hello,

Basically widget and theme don't support GrandNode 4.40. It may not work as expected. If the bugs exist in 4.30 we will fix them, but version 4.40 will be supported after official release.

Best,
Patryk
0
  • Posted: Monday, December 17, 2018 12:51 PM
  • 48
Thanks for getting back to me, I must have pulled the dev branch rather than the 4.30 release then.  Sorry about the confusion there.
0