Monday, January 27, 2020 2:53:32 AM
  • Posted: Thursday, January 9, 2020 6:30 PM
  • 52
Hi

please i have 2 language in my site (EN, AR)

and i have enable seo frindly url - to get lang in url like (en or ar .....)

no i have url as

EN: www.musite.com/en/men
AR: www.musite.com/ar/رجالى


now i need all url to be in English only even i view other language like that:

EN: www.musite.com/en/men
AR: www.musite.com/ar/men


so please any way to do that ?

thanks a lot ..
0
  • Posted: Friday, January 10, 2020 7:00 AM
  • Moderator
  • 414
Hi,

Just change SeNames in the SEO tab on each item edition screen. I.e Admin panel -> Catalog -> Products -> Edit particular product -> SEO tab -> Tab with languages. Delete existing SeNames and set single SeName in the Standard tab. Then if you switch language, you will have always SeName taken from Standard tab.
0
  • Posted: Friday, January 10, 2020 11:42 PM
  • 52
Patryk wrote:
Hi,

Just change SeNames in the SEO tab on each item edition screen. I.e Admin panel -> Catalog -> Products -> Edit particular product -> SEO tab -> Tab with languages. Delete existing SeNames and set single SeName in the Standard tab. Then if you switch language, you will have always SeName taken from Standard tab.


Thanks a lot Patryk

i try to do as you told me but each time i click save i found that seo is added automatically again  to any other language like "English - Arabic" - so how can i make it works ?

so any other thing i must do in c# code ? or admin settings to avoid that ?
0
  • Posted: Saturday, January 11, 2020 5:59 PM
  • Moderator
  • 414
It looks like you have older version of GrandNode. This bug was fixed in GrandNode 4.20.
0
  • Posted: Sunday, January 12, 2020 9:16 AM
  • 52
Patryk wrote:
It looks like you have older version of GrandNode. This bug was fixed in GrandNode 4.20.


Thanks a lot for your concern

i have version 4.30 , please if you code help with part of c# code i must edit - because i can't update project final version ?

note: this is video from last version and its do the same as version i have - i think it must be an settings for that in admin but i don't know

https://vimeo.com/384307918?activityReferer=1

i hope to find solution

0
  • Posted: Sunday, January 12, 2020 9:56 AM
  • Moderator
  • 414
Yes, that's exatcly that what was fixed in 4.20 version. Please check this commit: https://github.com/grandnode/grandnode/commit/a530e571019e1dbf635899f3d4218f9f3c362135

I suppose it should help. But to be honest, I really recommend to update GrandNode to the newest version.
0