FAQ

GENERAL QUESTIONS

Is it compatible with nopCommerce?

Basically, no it's not. You can use our plugin to export data from nopCommerce to GrandNode. But you are not able to install plugins, theme created for nopCommerce in GrandNode. But it's very similar so it won't be difficult to create your own plugins and themes dedicated to GrandNode.

What I need to run GrandNode?

To run the newest GrandNode, you need to have web server which supports ASP.NET Core 2.0, working MongoDB database. Installation process is similar to nopCommerce installation.

No Source (Web) OR Source Code? Need help in deciding, which one to use?

Basically. Source code version is recommended for developers and users which are familiar with .NET. No source (web) version is ready to use package which can be uploaded to FTP and run. 

How can I upgrade GrandNode to the newest version?

GrandNode upgrading is a simple process. Please follow this steps:
Step 1. First of all for safety reasons, make a backup of your site, database. This will allow you to restore previous data, regardless of how the update finished.
Step 2. Download the newest package of GrandNode files.
Step 3. Copy Settings.txt and InstalledPlugins.txt files into App_Data directory (If you store images in GrandNode also  copy (\Content\Images\)).
Step 4. Replace GrandNode files with new version files.
Step 4. Run http://yourdomain.com/upgrade
Step 5. After finish copy back Settings.txt and InstalledPlugins.txt files into App_Data directory and (\Content\Images\).
Step 6. Restart your application.
Step 7. That's all.