Thursday, September 19, 2019 12:25:58 PM
  • Posted: Tuesday, June 11, 2019 5:36 AM
  • Moderator
  • 317
It's strange, but please don't copy the command, just enter it manually, it should does the trick.
0
  • Posted: Tuesday, June 11, 2019 6:31 AM
  • 9
Patryk wrote:
It's strange, but please don't copy the command, just enter it manually, it should does the trick.

yes, that did solve it
The problem was the dash in your blog
0
  • Posted: Tuesday, June 11, 2019 6:57 AM
  • 9
Hi again,

I've done all the steps, but after running it from the browser, it only displays Welcome to nginx!
What steps did I missed?
0
  • Posted: Tuesday, June 11, 2019 7:06 AM
  • Moderator
  • 317
Something is wrong with the reverse proxy settings I guess.
0
  • Posted: Tuesday, June 11, 2019 2:57 PM
  • 9
Patryk wrote:
Something is wrong with the reverse proxy settings I guess.

This is the /etc/nginx/conf.d/default.conf
server {
listen 80;
location / {
proxy_pass http://localhost:5000;
proxy_http_version 1.1;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection keep-alive;
proxy_set_header Host $host;
proxy_cache_bypass $http_upgrade;
}
}

This is the /etc/nginx/nginx.conf
user www-data;
worker_processes auto;
pid /run/nginx.pid;

events {
  worker_connections 768;
  # multi_accept on;
}

http {

  ##
  # Basic Settings
  ##

  sendfile on;
  tcp_nopush on;
  tcp_nodelay on;
  keepalive_timeout 65;
  types_hash_max_size 2048;
  # server_tokens off;

  # server_names_hash_bucket_size 64;
  # server_name_in_redirect off;

  include /etc/nginx/mime.types;
  default_type application/octet-stream;

  ##
  # SSL Settings
  ##

  ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
  ssl_prefer_server_ciphers on;

  ##
  # Logging Settings
  ##

  access_log /var/log/nginx/access.log;
  error_log /var/log/nginx/error.log;

  ##
  # Gzip Settings
  ##

  gzip on;
  gzip_disable "msie6";

  # gzip_vary on;
  # gzip_proxied any;
  # gzip_comp_level 6;
  # gzip_buffers 16 8k;
  # gzip_http_version 1.1;
  # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;

  ##
  # Virtual Host Configs
  ##

  include /etc/nginx/conf.d/*.conf;
  include /etc/nginx/sites-enabled/*;
  include /etc/nginx/proxy.conf;
}


#mail {
#  # See sample authentication script at:
#  # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#  # auth_http localhost/auth.php;
#  # pop3_capabilities "TOP" "USER";
#  # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#  server {
#    listen     localhost:110;
#    protocol   pop3;
#    proxy      on;
#  }
#
#  server {
#    listen     localhost:143;
#    protocol   imap;
#    proxy      on;
#  }
#}

And this is the /etc/nginx/proxy.conf
proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
client_max_body_size 10m;
client_body_buffer_size 128k;
proxy_connect_timeout 90;
proxy_send_timeout 90;
proxy_read_timeout 90;
proxy_buffers 32 4k;
0
  • Posted: Tuesday, June 11, 2019 3:01 PM
  • 9
I'm using nginx/1.10.3 on Ubuntu 16.04.6
0