Sunday, August 18, 2019 9:32:22 AM
  • Posted: Sunday, October 7, 2018 2:39 PM
  • 8
Orders do not get pass the 1. Billing address. when selecting the address and click Continue it goes back to the Shopping Cart

Followed the instructions from GrandNode Blog with installation as follows:

Version of GrandNode: 4.20.01
Version of MongoDB: 4.0.2
OS: Ubuntu 16.04.5 on Digital Ocean
NGINX version 1.14.0
Both GrandNode and MongoDB on the same droplet.

Everything seams to work fine in the Admin Panel when adding/updating products or Categories, until trying to complete an order.
I add an item(s) to the shopping cart,
1. select Go To Cart,
2. Check :I agree with the terms of service and I adhere to them unconditionally(read)
3. Click: Checkout
4. Takes me to the first step 1. Billing address: Select an address (or type a new address)
5, Click Continue and it takes me back to the shopping card.
It does not get pass the 1. Billing address

Please advise
Thank you.
Paul.
0
  • Posted: Sunday, October 7, 2018 2:46 PM
  • 8
Setup Continued (firewall)
-ufw firewall in Ubuntu: enabled or disabled - same behaviour
-Digital Ocean firewall:
Inbound Rules on: for HTTP   TCP   80 and 443   for All IPv4 All IPv6
Outbound Rules on: ICMP, All TCP, All UDP for All IPv4 All IPv6
0
  • Posted: Thursday, January 24, 2019 3:58 AM
  • 8
Did u fix it?
0
  • Posted: Sunday, February 3, 2019 5:01 AM
  • 49
Paul,

If you open up developer tools (i.e. F12) on Chrome/Edge/etc.  Do you see warnings in your console about Mixed Content Type?  If so, you might want to check out this forum thread, additionally GrandNode folks put together an SSL guide .  If you are still having issues, double check that you set "UseHttpXForwardedProto" to true in your appsettings.json (App_Data/appsettings.json).  

Hopefully that gets you sorted. All the best.
0