Wednesday, March 20, 2019 3:35:40 PM
  • Posted: Friday, December 21, 2018 12:51 AM
  • 44
hi
i try to enable ExternalAuth.Facebook in my web site so i have add all data i need

after create the app in facebook



and then



and set Valid OAuth Redirect URIs as : https://www.alphamall.net/signin-facebook

but each time i click sign in face book but in the site i got this



so please how can i make it works - every thing as you c is write ???!!!!!
0
  • Posted: Friday, December 21, 2018 7:23 AM
  • Moderator
  • 199
Hello,

You received facebook error. I tested it on our dev environment and it works fine.

Best,
Patryk
0
  • Posted: Friday, December 21, 2018 4:25 PM
  • 44
i try it now and still get the same error ? so what i can do please ?
0
  • Posted: Friday, December 21, 2018 4:33 PM
  • 44
my grand ver is 4.20.01
0
  • Posted: Friday, December 21, 2018 4:36 PM
  • 44
you can try : https://www.alphamall.net and try login by facebook you will got the same error

you can see all configuration with this admin account:
test@admin.com
pwd: 123456

thanks a gain and hope to get help to make it working
0
  • Posted: Friday, December 21, 2018 5:41 PM
  • Moderator
  • 199
I got error that the connection is not secured. It can be the problem. I suppose you have something wrong in the configuration. Where do you host GrandNode? If you use Linux - nginx server, you probably have problems with https redirecting. It can be confusing and we eased up this process in the newest version of GrandNode. We added new setting to appsettings.json file - UseForwardedHeaders".  Updated guide about SSL installation can be found here.

Hope it will help you.
0
  • Posted: Friday, December 21, 2018 6:02 PM
  • 44
Thanks a lot Patryk

i have restart app an now i got them same error you got "Error code: 1349187
Error message: Insecure Login Blocked: You can't get an access token or log in to this app from an insecure page. Try re-loading the page as https://"

i host grand on "https://digitalocean.com" and i was use this topic to make site https (i do all steps here)

topic url: https://www.digitalocean.com/community/tutorials/how-to-secure-nginx-with-let-s-encrypt-on-ubuntu-16-04

and enable ssl on store settings and site working as https

so please how can i make it works ?
0
  • Posted: Friday, December 21, 2018 6:07 PM
  • 44
Note i found "ForwardedHttpHeader" in appsettings.json file but i don't know what value i must add to it ?
0
  • Posted: Thursday, December 27, 2018 11:13 AM
  • Moderator
  • 8
Ahmed wrote:
Note i found "ForwardedHttpHeader" in appsettings.json file but i don't know what value i must add to it ?

Please have a look on this post.
Hope it will help you.
0
  • Posted: Thursday, December 27, 2018 5:41 PM
  • Moderator
  • 21
Hi,

Please update your version to the latest 4.30

Regards
Krzysztof
0